<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head profile="http://gmpg.org/xfn/11">
	<title>Seven Trippy Modern Psych-Rock Concept Albums on Bandcamp &laquo; Bandcamp Daily</title>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<link rel="stylesheet" href="https://s0.wp.com/wp-content/themes/pub/sandbox-162/style.css" type="text/css" media="screen" />
	<link rel="pingback" href="https://daily.bandcamp.com/xmlrpc.php" />
				<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=daily.bandcamp.com&amp;id=4823170&amp;t=1512145357&amp;back=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F12%2F01%2Fmodern-psych-rock-concept-albums-on-bandcamp%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//bandcampblog.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Bandcamp Daily &raquo; Feed" href="https://daily.bandcamp.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bandcamp Daily &raquo; Comments Feed" href="https://daily.bandcamp.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bandcamp Daily &raquo; Seven Trippy Modern Psych-Rock Concept Albums on&nbsp;Bandcamp Comments Feed" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyNkdFOwzAMRX8IExUQGw+Ib0lTk3lLYqt2NfH3uGyTtmmKeIl8k3PiWAlHgcTNsFmoC0hZMjUNhQ6oYY8mMR3gLz0n1afwGJ+xRMMJhNXuUk9LPKPvV4m2EhUniliwOtbTqrxfrLXc+RO7bY7iNIyjzKgKvlZaKtjOG/U9mjL6PMZynkztp+B/FOVEsQA5chtOMoXGdjq8FL1bMzIUTtGI202A7xJp7v/MWDh7mYNTV3GVvurn8PaxedkOw+uw/wW9HcRx' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-1-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bandcampblog.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Ora Cogan’s Haunting, Ethereal “Crickets” Confronts Environmental&nbsp;Destruction' href='https://daily.bandcamp.com/2017/12/01/ora-cogan-crickets-interview/' />
<link rel='next' title='Hi Bias: Notable Cassette Releases on Bandcamp, November&nbsp;2017' href='https://daily.bandcamp.com/2017/12/01/hi-bias-november-2017/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/" />
<link rel='shortlink' href='https://wp.me/pkeJ4-lJb' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F12%2F01%2Fmodern-psych-rock-concept-albums-on-bandcamp%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F12%2F01%2Fmodern-psych-rock-concept-albums-on-bandcamp%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Seven Trippy Modern Psych-Rock Concept Albums on Bandcamp" />
<meta property="og:url" content="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/" />
<meta property="og:description" content="From a tragic mythical creature to a time traveling Aaron Burr, the tracks on these seven releases unveil epic narratives." />
<meta property="article:published_time" content="2017-12-01T14:42:09+00:00" />
<meta property="article:modified_time" content="2017-12-01T14:42:09+00:00" />
<meta property="og:site_name" content="Bandcamp Daily" />
<meta property="og:image" content="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@Bandcamp" />
<meta name="twitter:text:title" content="Seven Trippy Modern Psych-Rock Concept Albums on&nbsp;Bandcamp" />
<meta name="twitter:image:src" content="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Bandcamp" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel='openid.server' href='https://bandcampblog.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://bandcampblog.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://daily.bandcamp.com/osd.xml" title="Bandcamp Daily" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style id="wpcom-hotfix-masterbar-style">
			@media screen and (min-width: 783px) {
				#wpadminbar .quicklinks li#wp-admin-bar-my-account.with-avatar > a img {
					margin-top: 5px;
				}
			}
		</style>
		<meta name="application-name" content="Bandcamp Daily" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://daily.bandcamp.com/feed/;icon-uri=https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="Seven Trippy Modern Psych-Rock Concept Albums on&nbsp;Bandcamp | Bandcamp Daily on WordPress.com" />
<meta name="description" content="From a tragic mythical creature to a time traveling Aaron Burr, the tracks on these seven releases unveil epic narratives." />
<link rel="amphtml" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<link rel="icon" href="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=180" />
<meta name="msapplication-TileImage" content="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=270" />
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=keJ4&#038;cscache=6&#038;csrev=402" />
		</head>

<body class="wordpress y2017 m12 d01 h08 single postid-83525 s-y2017 s-m11 s-d30 s-h22 s-category-featured-music s-tag-concept-albums s-tag-king-gizzard-the-lizard-wizard s-tag-psychedelic-rock s-author-featurestoriesblog mp6 customizer-styles-applied highlander-enabled highlander-light">

<div id="wrapper" class="hfeed">
	<div id="header">
		<h1 id="blog-title"><span><a href="https://daily.bandcamp.com/" title="Bandcamp Daily" rel="home">Bandcamp Daily</a></span></h1>
		<div id="blog-description"></div>
	</div><!--  #header -->

	<div id="access">
		<div class="skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
		<div class="menu-header"><ul id="menu-header-links" class="menu"><li id="menu-item-82821" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-82821"><a href="https://daily.bandcamp.com/category/featured-music/">Latest</a></li>
<li id="menu-item-82820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82820"><a href="https://daily.bandcamp.com/category/top-stories/">Top Stories</a></li>
<li id="menu-item-82822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-82822"><a href="https://daily.bandcamp.com/category/bandcamp/">Bandcamp Updates</a></li>
</ul></div>	</div><!-- #access -->

	<div id="container">
		<div id="content">


			<div id="nav-above" class="navigation">
				<div class="nav-previous"><a href="https://daily.bandcamp.com/2017/12/01/ora-cogan-crickets-interview/" rel="prev"><span class="meta-nav">&laquo;</span> Ora Cogan’s Haunting, Ethereal “Crickets” Confronts Environmental&nbsp;Destruction</a></div>
				<div class="nav-next"><a href="https://daily.bandcamp.com/2017/12/01/hi-bias-november-2017/" rel="next">Hi Bias: Notable Cassette Releases on Bandcamp, November&nbsp;2017 <span class="meta-nav">&raquo;</span></a></div>
			</div>

			<div id="post-83525" class="hentry p1 post publish author-editorial category-featured-music tag-concept-albums tag-king-gizzard-the-lizard-wizard tag-psychedelic-rock y2017 m11 d30 h22">
				<h2 class="entry-title">Seven Trippy Modern Psych-Rock Concept Albums on&nbsp;Bandcamp</h2>
				<div class="entry-content">
<div data-shortcode="caption" id="attachment_83634" style="max-width: 1254px" class="wp-caption alignnone"><img data-attachment-id="83634" data-permalink="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/moonduo-1244-1/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=800" data-orig-size="1244,646" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="moonduo-1244-1" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=800?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=800?w=800" class="alignnone size-full wp-image-83634" src="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=800" alt="moonduo-1244-1" srcset="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=800 800w, https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=300 300w, https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=768 768w, https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg?w=1024 1024w, https://bandcampblog.files.wordpress.com/2017/11/moonduo-1244-1.jpg 1244w" sizes="(max-width: 800px) 100vw, 800px"   /><p class="wp-caption-text">Moon Duo</p></div>
<p class="p1">The Beatles are credited with having invented nearly everything. This includes the very first concept album in the form of <i>Sgt. Pepper’s Lonely Hearts Club Band</i>, even though The Fab Four confessed that they failed to follow the concept through to fruition. After that, the idea of basing an album around one overriding theme was embraced with gusto by the prog bands of the 1970s, with their ostentatious rock operas. More recently however, everyone from Green Day to Beyoncé have jumped on the conceptual wagon. No doubt The Beatles would have been pleased to see that the concept album remains in excellent health, particularly in a genre they were fundamental in pioneering: psychedelic rock music. From those inspired by L.A. noir crime scenes to diversions into Chinese philosophy, here are some of the best psych-rock concept albums on Bandcamp.<span id="more-83525"></span></p>
<h3 class="p1">King Gizzard &amp; The Lizard Wizard, <em><a href="https://kinggizzard.bandcamp.com/album/murder-of-the-universe" target="_blank" rel="noopener">Murder Of The Universe</a></em></h3>
<p class="p1"><i><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=1787442871/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe></i></p>
<p>King Gizzard &amp; The Lizard Wizard can produce concept albums in their sleep. They’ve probably released about eight new ones since you began reading this sentence. Offering three for the price of one and veering dangerously close to outright prog territory, <em>Murder</em> <i>Of The Universe</i>’s 21 tracks are grouped into three separate chapters. The first tells the tragic tale of a human/beast hybrid creature. The second narrates a conflict between two entities known as “Balrog” and “The Lord Of Lightning.” The third is about a robot who yearns for the ability to regurgitate. The album is mostly set to a frantic pace propelled forward by the band’s two drummers and the guitars are soaked in so much fuzz and wah that it would be easy to lose track of the crazy antics of &#8220;The Altered Beast,&#8221; &#8220;Balrog,&#8221; and &#8220;Han-Tyumi The Confused Cyborg.&#8221; The spoken word narration from guest vocalist Leah Senior should help you get a handle on the storytelling, though.</p>
<h3 class="p1">Circle, <i><a href="https://circlefinland.bandcamp.com/album/pori" target="_blank" rel="noopener">Pori</a></i></h3>
<p class="p1"><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=3297817907/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe></p>
<p>Unlike your proggier concept albums about scary dragons or interstellar space travel, <i>Pori</i>’s focus is—literally—closer to home. The experimental Finnish collective’s fifth album takes inspiration from Circle’s hometown of Pori where the band was formed in 1991. The group <a href="https://daily.bandcamp.com/2017/06/21/finland-circle-guide/" target="_blank" rel="noopener">has a habit of singing in their own made-up language</a> called Meronian,<b> </b>and much of this record is instrumental, so its concept might not translate all that easily to outsiders. Harder to resist is the music’s winning blend of prog, psych, krautrock, post-punk, ambient synthscapes, space-rock, and jazz.</p>
<h3 class="p1">White Hills, <em><a href="https://whitehills.bandcamp.com/album/h-p1" target="_blank" rel="noopener">H-P1</a></em></h3>
<p class="p1"><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=3803049148/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe></p>
<p class="p1">The breakout album by this New York-based space-rock combo was inspired by White Hills’ disgruntlement with unfettered consumerism, big corporations’ stranglehold over both government and the individual, and the general “disease of greed” which has tarnished humanity. Its imposing riffs, moments of no wave noise, ominous synth tones, and misanthropic lyrics certainly make for an angry record, although that belies how much fun and far-out the listening experience can be. Envisage a marginally grumpier Hawkwind and you’re halfway there.</p>
<h3 class="p3"><span class="s3">Moon Duo, <em><a href="https://moonduo.bandcamp.com/album/occult-architecture-vol-1" target="_blank" rel="noopener">Occult Architecture Volumes 1 &amp; 2</a></em><i><br />
</i></span></h3>
<p class="p1"><i><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=4036314295/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe> </i></p>
<p>Inspired by Chinese philosophy, this concept album comes in two separate installments. <a href="https://moonduo.bandcamp.com/album/occult-architecture-vol-1" target="_blank" rel="noopener"><em>Volume 1</em></a><i> </i>represents the yin (darkness, night, earth) whereas <a href="https://moonduo.bandcamp.com/album/occult-architecture-vol-2" target="_blank" rel="noopener"><em>Volume 2</em></a> is the yang (sun, light, heaven). Predictably, the second volume is the cheerier of the pair and to make sure of that, it was mixed at the height of the Pacific Northwestern summer. <i>Volume 1</i>, on the other hand, is steeped in death, Satan, Aleister Crowley, and Moloch, a biblical figure known for devouring children. Having said that, even on the more morbid of their two chapters, <i>Moon Duo </i>can’t abandon the signature warmth of their fuzzy distortions and groovy retro keyboard textures.</p>
<h3 class="p1"><img data-attachment-id="83615" data-permalink="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/skiptracing-1244/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=800" data-orig-size="1244,646" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Skiptracing-1244" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=800?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=800?w=800" class="alignnone size-full wp-image-83615" src="https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=800" alt="Mild High Club" srcset="https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=800 800w, https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=300 300w, https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=768 768w, https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg?w=1024 1024w, https://bandcampblog.files.wordpress.com/2017/11/skiptracing-1244.jpg 1244w" sizes="(max-width: 800px) 100vw, 800px"   /></h3>
<h3>Mild High Club, <em><a href="https://mildhighclub.bandcamp.com/album/skiptracing" target="_blank" rel="noopener">Skiptracing</a></em></h3>
<p class="p1"><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=4211984975/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe></p>
<p class="p1">Here’s one from the woozier, almost lounge music end of the psych-rock spectrum. Mild High Club’s Alexander Brettin is a jazz graduate with a soft rock fixation who specializes in laidback and melodic homebrewed psych tunes. <i>Skiptracing</i>’s lyrics are inspired by L.A. crime noirs such as <i>The Long Goodbye</i> and <i>Chinatown</i>.<span class="Apple-converted-space"> </span>With several listens under your belt, you’ll still have no clear idea who the culprit might be or even what the crime was. After all, the track titled “¿Whodunit?” is an ambiguously instrumental affair. Rather, you might feel like Doc Sportello at the end of <i>Inherent Vice</i>: stoned on the couch, wondering what just happened. Nothing wrong with that. Closure and resolution have always been overrated.</p>
<h3 class="p1">Pontiak, <em><a href="https://pontiak.bandcamp.com/album/living" target="_blank" rel="noopener">Living</a></em></h3>
<p class="p1"><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=1937278011/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe></p>
<p class="p1">The writer Dorian Lynskey has said that the resurgence of the concept album can be seen as a reaction against the rise of the MP3, streaming sites, and playlist culture. Pontiak’s <i>Living</i> is a case in point. In 2010, faced with the mounting dominance of single-song downloads, the Virginian siblings of Pontiak were determined to create an album that demanded being heard uninterrupted from beginning to end. It works. Singer Van Carney’s narrative arc covers a broad scope of<span class="Apple-converted-space"> </span>geographical terrain, and includes a character called “Lemon Lady,” while the music seamlessly fluctuates between chunky desert riffs, stomping blues rock, sludgy jams, and the occasional quieter moment of acoustic introspection.</p>
<h3 class="p1">Endless Boogie, <em><a href="https://endlessboogie.bandcamp.com/album/vibe-killer" target="_blank" rel="noopener">Vibe Killer</a></em></h3>
<p class="p1"><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/album=4115640482/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe></p>
<p class="p1">You could be forgiven for thinking that Endless Boogie are obsessed with one era exclusively—specifically, the 1970s. They’re named after a 1971 John Lee Hooker album, and their style is a resuscitation of the greased-up, southern-fried &#8217;70s rock jams of yore, complete with enough freewheelin’ noodly guitar solos to fill a ravine. It turns out they’re also interested in events of the 18th and 19th centuries as <i>Vibe Killer</i> is inspired by Aaron Burr, the disgraced third Vice President of the United States. Maybe Endless Boogie’s interest stems from Gore Vidal’s book <i>Burr: A Novel</i>, which was published in 1973. By track five, Burr appears to have been transported over 100 years into the future so that he can drop acid at an early Kiss concert. Perhaps the concept here could be considered as fairly “loose.”</p>
<h5 class="p1"><i>&#8211;</i>JR Moores</h5>
<p>&nbsp;</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-83525" class="share-twitter sd-button share-icon no-text" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-83525" class="share-facebook sd-button share-icon no-text" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-83525" class="share-google-plus-1 sd-button share-icon no-text" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>
				</div>
				<div class="entry-meta">
					This entry was written by <span class="author vcard"><a class="url fn n" href="https://daily.bandcamp.com/author/featurestoriesblog/" title="View all posts by Editorial">Editorial</a></span>, posted on <abbr class="published" title="2017-12-01T06:42:09-0800">December 1, 2017 at 6:42 am</abbr>, filed under <a href="https://daily.bandcamp.com/category/featured-music/" rel="category tag">featured music</a> and tagged <a href="https://daily.bandcamp.com/tag/concept-albums/" rel="tag">Concept Albums</a>, <a href="https://daily.bandcamp.com/tag/king-gizzard-the-lizard-wizard/" rel="tag">King Gizzard &amp; The Lizard Wizard</a>, <a href="https://daily.bandcamp.com/tag/psychedelic-rock/" rel="tag">Psychedelic Rock</a>. Bookmark the <a href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/" title="Permalink to Seven Trippy Modern Psych-Rock Concept Albums on&nbsp;Bandcamp" rel="bookmark">permalink</a>. Follow any comments here with the <a href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/feed/" title="Comments RSS to Seven Trippy Modern Psych-Rock Concept Albums on&nbsp;Bandcamp" rel="alternate" type="application/rss+xml">RSS feed for this post</a>.
					<a class="comment-link" href="#respond" title="Post a comment">Post a comment</a> or leave a trackback: <a class="trackback-link" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/trackback/" title="Trackback URL for your post" rel="trackback">Trackback URL</a>.
				</div>
			</div><!-- .post -->

			<div id="nav-below" class="navigation">
				<div class="nav-previous"><a href="https://daily.bandcamp.com/2017/12/01/ora-cogan-crickets-interview/" rel="prev"><span class="meta-nav">&laquo;</span> Ora Cogan’s Haunting, Ethereal “Crickets” Confronts Environmental&nbsp;Destruction</a></div>
				<div class="nav-next"><a href="https://daily.bandcamp.com/2017/12/01/hi-bias-november-2017/" rel="next">Hi Bias: Notable Cassette Releases on Bandcamp, November&nbsp;2017 <span class="meta-nav">&raquo;</span></a></div>
			</div>

			<div id="comments">



<div class="navigation">
 </div>

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://daily.bandcamp.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="5d2abe1c45" /><input type="hidden" name="_wp_http_referer" value="/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='83525' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="82ad695956" /></p>
<input type="hidden" name="genseq" value="1512145357" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="30"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
			</div><!-- #comments -->


		</div><!-- #content -->
	</div><!-- #container -->

	<div id="primary" class="sidebar">
				<ul class="xoxo">

			<li id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="top-stories">
<div class="linky-1"><a href="/category/top-stories/">Top Stories</a></div>
<ul class="display-posts-listing"><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/11/29/the-best-new-soul-on-bandcamp-november-2017/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/bns-600-november.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Best New Soul" srcset="https://bandcampblog.files.wordpress.com/2017/11/bns-600-november.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/bns-600-november.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83360" data-permalink="https://daily.bandcamp.com/2017/11/29/the-best-new-soul-on-bandcamp-november-2017/bns-600-november/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/bns-600-november.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BNS-600-November" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/bns-600-november.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/bns-600-november.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/11/29/the-best-new-soul-on-bandcamp-november-2017/">The Best New Soul on Bandcamp: November&nbsp;2017</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/11/29/the-vitamin-b12-feature/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/vitamin-b12-600-6.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Vitamin B12" srcset="https://bandcampblog.files.wordpress.com/2017/11/vitamin-b12-600-6.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/vitamin-b12-600-6.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83391" data-permalink="https://daily.bandcamp.com/2017/11/29/the-vitamin-b12-feature/vitamin-b12-600-6/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/vitamin-b12-600-6.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Vitamin-B12-600-6" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/vitamin-b12-600-6.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/vitamin-b12-600-6.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/11/29/the-vitamin-b12-feature/">The Vitamin B12 Remains an Elusive Figure in European&nbsp;Improv</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/11/29/best-new-ambient-november-2017/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/best-ambient-nov-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Best Ambient" srcset="https://bandcampblog.files.wordpress.com/2017/11/best-ambient-nov-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/best-ambient-nov-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83475" data-permalink="https://daily.bandcamp.com/2017/11/29/best-new-ambient-november-2017/best-ambient-nov-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/best-ambient-nov-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="best-ambient-nov-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/best-ambient-nov-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/best-ambient-nov-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/11/29/best-new-ambient-november-2017/">The Best New Ambient Music on Bandcamp, October/November 2017</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/11/28/lakeshore-records-label-profile/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/label-lakeshore-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Lakeshore Recs" srcset="https://bandcampblog.files.wordpress.com/2017/11/label-lakeshore-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/label-lakeshore-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83375" data-permalink="https://daily.bandcamp.com/2017/11/28/lakeshore-records-label-profile/label-lakeshore-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/label-lakeshore-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="label-lakeshore-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/label-lakeshore-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/label-lakeshore-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/11/28/lakeshore-records-label-profile/">A Guide to Lakeshore Records’ Dark, Retro-Centric&nbsp;Soundtracks</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/11/27/dfa-records-feature/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/label-dfa-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="DFA records" srcset="https://bandcampblog.files.wordpress.com/2017/11/label-dfa-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/label-dfa-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83200" data-permalink="https://daily.bandcamp.com/2017/11/27/dfa-records-feature/label-dfa-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/label-dfa-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="label-DFA-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/label-dfa-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/label-dfa-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/11/27/dfa-records-feature/">The Expansive Catalogue of DFA&nbsp;Records</a></li></ul>

</div></div>
			</li>

			<li id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="lists-below">


	<div class="most-recent">

		<div class="linky-1">Latest</div>

		<ul class="display-posts-listing"><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/12/01/hi-bias-november-2017/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/hi-bias-nov.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/11/hi-bias-nov.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/hi-bias-nov.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83501" data-permalink="https://daily.bandcamp.com/2017/12/01/hi-bias-november-2017/hi-bias-nov-2/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/hi-bias-nov.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="hi-bias-nov" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/hi-bias-nov.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/hi-bias-nov.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/12/01/hi-bias-november-2017/">Hi Bias: Notable Cassette Releases on Bandcamp, November 2017</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83633" data-permalink="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/moonduo-1/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="moonduo-1" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/moonduo-1.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/">Seven Trippy Modern Psych-Rock Concept Albums on Bandcamp</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/12/01/ora-cogan-crickets-interview/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/11/ora-cogan-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Ora Cogan" srcset="https://bandcampblog.files.wordpress.com/2017/11/ora-cogan-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/ora-cogan-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83581" data-permalink="https://daily.bandcamp.com/2017/12/01/ora-cogan-crickets-interview/ora-cogan-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/ora-cogan-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ora-Cogan-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/ora-cogan-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/ora-cogan-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/12/01/ora-cogan-crickets-interview/">Ora Cogan’s Haunting, Ethereal “Crickets” Confronts Environmental Destruction</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/12/01/ivan-ave-every-eye-album-review/" style="display: block;"><img width="150" height="150" src="https://bandcampblog.files.wordpress.com/2017/11/a2069579500_10.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/11/a2069579500_10.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/11/a2069579500_10.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="83564" data-permalink="https://daily.bandcamp.com/2017/12/01/ivan-ave-every-eye-album-review/a2069579500_10/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/11/a2069579500_10.jpg" data-orig-size="1200,1200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="a2069579500_10" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/11/a2069579500_10.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/11/a2069579500_10.jpg?w=800" /></a> <a class="title" href="https://daily.bandcamp.com/2017/12/01/ivan-ave-every-eye-album-review/">Album of the Day: Ivan Ave, “Every Eye”</a></li></ul>
		<div class="linky"><a href="/category/featured-music/">See All Stories › </a></div>

	</div>



	<div class="right side">

		<div class="weekly">

			<div class="linky-1">On Bandcamp Radio</div>

			<div class="weeklyimg">
				<a href="http://bandcamp.com/?play=1"></a>

				<div class="linky-2">

					<div class="weekly-title">Check out the newest episode of the Bandcamp Weekly.</div>
					<div class="linky"><a href="http://bandcamp.com/?play=1">Listen Now &rsaquo; </a></div>

			    </div>

			</div>
		</div>



		<div class="bandcamp-updates">

			<div class="linky-1">Bandcamp Updates</div>

			<ul class="display-posts-listing"><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/31/introducing-the-bandcamp-app-for-artists-and-labels/" style="display: block;"><img width="150" height="78" src="https://bandcampblog.files.wordpress.com/2017/10/artistapp-1244x646.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/10/artistapp-1244x646.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/artistapp-1244x646.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="80054" data-permalink="https://daily.bandcamp.com/2017/10/31/introducing-the-bandcamp-app-for-artists-and-labels/artistapp-1244x646/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/artistapp-1244x646.jpg" data-orig-size="1244,646" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="artistapp-1244&#215;646" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/artistapp-1244x646.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/artistapp-1244x646.jpg?w=800" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/31/introducing-the-bandcamp-app-for-artists-and-labels/">Introducing the Bandcamp App for Artists and Labels</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/09/12/announcing-bulk-edit/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Announcing Bulk Edit" srcset="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="65987" data-permalink="https://daily.bandcamp.com/2017/09/12/announcing-bulk-edit/bulk-edit-1-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="bulk-edit-1-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/09/12/announcing-bulk-edit/">Announcing Bulk Edit</a></li></ul>
			<div class="linky"><a href="/category/bandcamp/">See All Updates › </a></div>

		</div>

	</div>


</div></div>
			</li>
			
			<li id="search" class="widget widget_search">				
				<h3 class="widgettitle"><label for="s"> &nbsp;</label></h3>
				<form id="searchform" class="blog-search" method="get" action="https://daily.bandcamp.com/">
					<div>
						<input id="s" name="s" type="text" class="text" value="" size="10" tabindex="1" />
						<input type="submit" class="button" value="Go" tabindex="2" />
					</div>
				</form>
			
			</li>
		</ul>
	</div><!-- #primary .sidebar -->

	<div id="secondary" class="sidebar">
		<ul class="xoxo">

			<li id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="header-links">

<a href="/category/featured-music/">Latest</a>

<a href="/category/top-stories/">Top Stories</a>

</div></div>
			</li>

			<li id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="follow-us">
</a>
<a class="social-facebook" href="https://www.facebook.com/Bandcamp/" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-2.png"></a>
<a class="social-twitter" href="https://twitter.com/Bandcamp" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-3.png"></a>
<a class="social-instagram" href="https://www.instagram.com/bandcamp" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-4.png"></a>
</div></div>
			</li>

			<li id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="footer">

	<div class="footer-add">

		<div class="blurb">Follow Us</div>
		<a class="social-facebook" href="https://www.facebook.com/Bandcamp/" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-2.png"></a>
		<a class="social-twitter" href="https://twitter.com/Bandcamp" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-3.png"></a>
		<a class="social-instagram" href="https://www.instagram.com/bandcamp" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-4.png"></a>
	</div>

	<div class="footer-right">

		<div class="blurb">Your guide to the world of Bandcamp</div>

		<a class="sidebarlogo" href="http://bandcamp.com"></a>
	</div>

</div></div>
			</li>
		</ul>
	</div><!-- #secondary .sidebar -->
<script type='text/javascript'>
								var _gaq = _gaq || [];
								_gaq.push(['_setAccount', 'UA-4189134-6']);
_gaq.push(['_trackPageview']);

								(function() {
									var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
									ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
									var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
								})();
							</script>

	<div id="footer">
		<span id="generator-link"><a></a></span>
		<span class="meta-sep">|</span>
		</span>
	</div><!-- #footer -->

</div><!-- #wrapper .hfeed -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201748y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/bandcampblog.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/bandcampblog.wordpress.com\/wp-login.php?action=logout&_wpnonce=d329d125b6","homeURL":"https:\/\/daily.bandcamp.com\/","postID":"83525","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="4823170" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://daily.bandcamp.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Bandcamp Daily" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="6524c5c208" /><input type="hidden" name="_wp_http_referer" value="/2017/12/01/modern-psych-rock-concept-albums-on-bandcamp/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/daily.bandcamp.com\/2017\/12\/01\/modern-psych-rock-concept-albums-on-bandcamp\/":83525};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
		<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"4823170","siteName":"Bandcamp Daily","siteURL":"https:\/\/daily.bandcamp.com","icon":"<img alt='' src='https:\/\/bandcampblog.files.wordpress.com\/2017\/03\/bc-site-icon1.png?w=50' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/sandbox-162","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/bandcampblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F12%2F01%2Fmodern-psych-rock-concept-albums-on-bandcamp%2F","themeURL":"","xhrURL":"https:\/\/daily.bandcamp.com\/wp-admin\/admin-ajax.php","nonce":"4e25138951","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"0aa580f562\" \/>","referer":"https:\/\/daily.bandcamp.com\/2017\/12\/01\/modern-psych-rock-concept-albums-on-bandcamp\/","canFollow":"1","feedID":"49616248","statusMessage":"","customizeLink":"https:\/\/bandcampblog.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fbandcampblog.wordpress.com%2F2017%2F12%2F01%2Fmodern-psych-rock-concept-albums-on-bandcamp%2F","postID":"83525","shortlink":"https:\/\/wp.me\/pkeJ4-lJb","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/daily.bandcamp.com\/83525","statsLink":"https:\/\/wordpress.com\/stats\/post\/83525\/daily.bandcamp.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Sandbox 1.6.2","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 4,665 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/bandcampblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F12%2F01%2Fmodern-psych-rock-concept-albums-on-bandcamp%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/daily.bandcamp.com\/wp-admin\/admin-ajax.php","nonce":"6d9ca8e364","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/bandcampblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F12%2F01%2Fmodern-psych-rock-concept-albums-on-bandcamp%2F","blog_id":"4823170","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=4823170&v=wpcom&tz=-8&user_id=0&subd=bandcampblog","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVUNtuwjAM/aGlZoKC9jDtU6aQGnCaG3bCxt9jpJX1AVXiyda5+STwU4zLqWKq4AUGvJDD8tt5eYMZFZspoR0pCQQaUeDcsOHJpiEgT2JKLrRBSQ1yOUY1GsYSrl2ktJBoB+XN3jJEKxVZN5MvyEz3sAf2YkJl60ZZMrlKOd1Nj+3ZS6T8l5/jXr+Ar3+jm6ue3HKWcxMM4LEW7WUmYKnfSBKxmnW3gm+9DIfMcUFfslRzCJYY5GSZ0nGaavqKn+/96mO92/Tb3t8ABbS7Lg=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'4823170','blog_tz':'-8','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'4823170','v':'wpcom','tz':'-8','user_id':'0','post':'83525','subd':'bandcampblog'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1oV0pFNEwueXFaVXlyMGwvVG9ES35pOVYlRUVhdVJ2TTczd3dDaTdGUm83UEpzfHZlbl1HSkppTG05Rzh1fCxhSDBpPWlCW0kxR2puWUp3JWl6TENpPU5IUmt2LjBRckc9ZF1YU1s1SUYzSGh5OWgmK0lUbURLZ040fHZWUzNlZz1bOGZpbEJdP0tFeWFUN3pPUHZfaDZSX2YyRUh6JkZ2bTksNi4uNGdXMkVNeUNra1tzK2VlXTAuamx+LU5QdU5yN1g2X0FuYVRwbF95TXpubGEvRUY9Smg9ci8vSEU3bWp1bnJUZHp+PWxtTGclc3Uzb1J3Pz1MSzRaeVU5VnJlJT9+NWZhc2EwVXFkfCVQXXg='}]);
_stq.push([ 'clickTrackerInit', '4823170', '83525' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
<!--
	generated 59 seconds ago
	generated in 0.082 seconds
	served from batcache in 0.001 seconds
	expires in 241 seconds
-->
