<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head profile="http://gmpg.org/xfn/11">
	<title>Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland” &laquo; Bandcamp Daily</title>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<link rel="stylesheet" href="https://s0.wp.com/wp-content/themes/pub/sandbox-162/style.css" type="text/css" media="screen" />
	<link rel="pingback" href="https://daily.bandcamp.com/xmlrpc.php" />
				<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=daily.bandcamp.com&amp;id=4823170&amp;t=1507330923&amp;back=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F10%2F06%2Fdont-call-it-synthwave-navigating-necro-deathmorts-overland%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//bandcampblog.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Bandcamp Daily &raquo; Feed" href="https://daily.bandcamp.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bandcamp Daily &raquo; Comments Feed" href="https://daily.bandcamp.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Bandcamp Daily &raquo; Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland” Comments Feed" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyNkdFuwyAMRX9oHkpXddtDtW8hxKNuAaPYUdq/r9OmmjpNaC/oXrgHG+PmCoGLYlGXJ6hpilTEJTqhuCNq9eEEN/caRF7c3/ERk1ccoLLoL9fCAo9o+7l6XRIZB/KYMFushc00RLQ6Flk1KJ6bSK67R6FFHuxVzc7mamno+zqiCNiaacqgB+utza2tKdd1GKKXhP9BhAP5BGSRZ3OHyRXW++FDtG6NyJA4eCUuTwa+k6ex/Zl94mgy3ib8YxfoK++77ef75qPr3rrjFVMn19U=' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-1-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-2-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bandcampblog.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Album of the Day: Daphni, “Joli&nbsp;Mai”' href='https://daily.bandcamp.com/2017/10/06/daphni-joli-mai-review/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/" />
<link rel='shortlink' href='http://wp.me/pkeJ4-jJz' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F10%2F06%2Fdont-call-it-synthwave-navigating-necro-deathmorts-overland%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F10%2F06%2Fdont-call-it-synthwave-navigating-necro-deathmorts-overland%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland”" />
<meta property="og:url" content="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/" />
<meta property="og:description" content="“Overland” captures Necro Deathmort poking around a dynamic range of sonic territories including astral jazz, krautrock grooves, and plenty of drone work." />
<meta property="article:published_time" content="2017-10-06T18:11:28+00:00" />
<meta property="article:modified_time" content="2017-10-06T18:12:04+00:00" />
<meta property="og:site_name" content="Bandcamp Daily" />
<meta property="og:image" content="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@Bandcamp" />
<meta name="twitter:text:title" content="Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland”" />
<meta name="twitter:image:src" content="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Bandcamp" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel='openid.server' href='https://bandcampblog.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://bandcampblog.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://daily.bandcamp.com/osd.xml" title="Bandcamp Daily" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
		<style id="wpcom-hotfix-masterbar-style">
			@media screen and (min-width: 783px) {
				#wpadminbar .quicklinks li#wp-admin-bar-my-account.with-avatar > a img {
					margin-top: 5px;
				}
			}
		</style>
		<meta name="application-name" content="Bandcamp Daily" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://daily.bandcamp.com/feed/;icon-uri=https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland” | Bandcamp Daily on WordPress.com" />
<meta name="description" content="“Overland” captures Necro Deathmort poking around a dynamic range of sonic territories including astral jazz, krautrock grooves, and plenty of drone work." />
<link rel="amphtml" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<link rel="icon" href="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=32" sizes="32x32" />
<link rel="icon" href="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=180" />
<meta name="msapplication-TileImage" content="https://bandcampblog.files.wordpress.com/2017/03/bc-site-icon1.png?w=270" />
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=keJ4&#038;cscache=6&#038;csrev=393" />
		</head>

<body class="wordpress y2017 m10 d06 h16 single postid-75861 s-y2017 s-m10 s-d06 s-h04 s-category-featured-music s-tag-electronic-music s-tag-necro-deathmort s-author-featurestoriesblog mp6 customizer-styles-applied highlander-enabled highlander-light">

<div id="wrapper" class="hfeed">
	<div id="header">
		<h1 id="blog-title"><span><a href="https://daily.bandcamp.com/" title="Bandcamp Daily" rel="home">Bandcamp Daily</a></span></h1>
		<div id="blog-description"></div>
	</div><!--  #header -->

	<div id="access">
		<div class="skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
		<div class="menu"></div>
	</div><!-- #access -->

	<div id="container">
		<div id="content">


			<div id="nav-above" class="navigation">
				<div class="nav-previous"><a href="https://daily.bandcamp.com/2017/10/06/daphni-joli-mai-review/" rel="prev"><span class="meta-nav">&laquo;</span> Album of the Day: Daphni, “Joli&nbsp;Mai”</a></div>
				<div class="nav-next"></div>
			</div>

			<div id="post-75861" class="hentry p1 post publish author-editorial category-featured-music tag-electronic-music tag-necro-deathmort y2017 m10 d06 h04">
				<h2 class="entry-title">Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland”</h2>
				<div class="entry-content">
<div data-shortcode="caption" id="attachment_75883" style="width: 610px" class="wp-caption alignnone"><img data-attachment-id="75883" data-permalink="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/necro-deathmort-by-eleanor-short-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=600&#038;h=400" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Necro-Deathmort-by-Eleanor-Short-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=600&#038;h=400?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=600&#038;h=400?w=600" class="alignnone size-full wp-image-75883" src="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=600&#038;h=400" alt="Necro Deathmort" width="600" height="400" srcset="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg 600w, https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=150&amp;h=100 150w, https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=300&amp;h=200 300w" sizes="(max-width: 600px) 100vw, 600px" /><p class="wp-caption-text">Photo by Eleanor Short.</p></div>
<p class="p1">Necro Deathmort’s music defies categorization as fiercely as David Lynch’s nonlinear narratives defy any single “correct” interpretation. Formed by Matthew Rozeik and AJ Cookson in 2007, the London-based duo have been steadily building an immense body of work which has straddled everything from industrial doom to abstract techno bangers—and almost everything in between.</p>
<p class="p1">Noticeably brighter and bubblier than the austere sound of 2016’s <i>The Capsule</i>, this year’s <i>Overland </i>makes greater use of acoustic instrumentation, and finds Necro Deathmort exploring a dynamic range of sonic territories, including astral jazz, krautrock grooves, noirish atmospherics, and plenty of spooky-to-soothing drone work.</p>
<p class="p1">Whereas <i>The Capsule</i> was a frostily ambient work released via Rocket Recordings (a label best known for psych rock), <i>Overland</i> comes courtesy of Profound Lore, home to extreme metal acts such as Portal and Pissgrave. This notion of finding a space in a place they might not naturally belong extends to Necro Deathmort&#8217;s live shows, where they feel just as comfortable playing metal events as they do performing alongside electronic artists—even though the latter happens less frequently. “Possibly we’re a bit negative for that kind of party,” reasons Rozeik. “[But] people into both types of music make up much of our fanbase, so we’re happy playing to anybody who wants to hear us, and we really like being on diverse bills. We’ve played with bands as relatively opposite as Napalm Death and Silver Apples. Hopefully, we’ll never have to choose our corner. Otherwise, it’s going to be mods versus rockers all over again.”</p>
<p><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/track=2212687823/album=1248245268/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe><span id="more-75861"></span></p>
<p class="p1">As countless listeners have already observed, Necro Deathmort’s abstract, cinematic style would make the perfect match for some epic space thriller or creepy supernatural horror movie, if only Cookson and Rozeik could get their foot in Hollywood’s door like Clint “Pop Will Eat Itself” Mansell or that dude from The Nine Inch Nails. But since their reputation hasn’t yet secured them the big motion picture or Netflix contract, the duo is in regular demand as remixers, and recently contributed production to the latest album by Steven Wilson of Porcupine Tree fame. Wilson has been a devoted fan of Necro Deathmort since the release of their second album, <i>Music Of Bleak Origin</i>, in 2011.</p>
<p class="p1">Here, Matthew Rozeik explains the thinking behind <i>Overland</i>, and how playing the wrong notes can often yield the best results.</p>
<p class="p1"><b>What was the concept behind <i>Overland</i>?<br />
</b></p>
<p class="p1"><i>The Capsule</i> had a theme of isolation, birth/death cycles, and the idea of an individual’s personal perspective in the universe. <i>Overland</i> is much more terrestrial. We wanted to evoke the sense of being in a specific environment, feet in the dirt, looking out rather than up. The lyrics are also focussed more on human nature rather than outer space and we tried not to make it sound too sci-fi or futuristic. The title just stuck when AJ came up with it. I think it fits the sound of the record perfectly.</p>
<p><img data-attachment-id="75885" data-permalink="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/necro-deathmort-by-eleanor-short-600-2/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600-2.jpg?w=600&#038;h=400" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Necro-Deathmort-by-Eleanor-Short-600-2" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600-2.jpg?w=600&#038;h=400?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600-2.jpg?w=600&#038;h=400?w=600" class="alignnone size-full wp-image-75885" src="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600-2.jpg?w=600&#038;h=400" alt="Necro Deathmort" width="600" height="400" srcset="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600-2.jpg 600w, https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600-2.jpg?w=150&amp;h=100 150w, https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600-2.jpg?w=300&amp;h=200 300w" sizes="(max-width: 600px) 100vw, 600px" /><iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/track=736637179/album=2351794094/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe></p>
<p class="p1"><b><i>Overland</i> has a warmer and more playful feel to it than <i>The Capsule</i>. There are some jazzier moments. The track &#8216;Gu&#8217; grooves along in an upbeat, almost poppy way. Is this a reflection of&#8230; something?</b></p>
<p class="p1">It’s probably a reflection of our ever-expanding musical interests more than anything. We always want each record to be different from the previous one. <i>The Capsule</i> was quite bleak and cold-sounding. This time we knew we wanted to do something a bit more lively and melodic. Using ‘real’ instruments was a conscious decision; we hoped it would enrich the album’s palette, and I think it worked. It’s always fun to see how far outside of our comfort zone we can take things. With regards to &#8216;Gu,&#8217; we actually did a whole record of up-tempo melodic tunes called <i>EP3</i> in 2015 but it seems to be our least known-about release.</p>
<p class="p1"><b>Necro Deathmort recently released a third album of archive material on Extreme Ultimate. What other unreleased delights do you have hidden away?</b></p>
<p class="p1">That was technically the fourth volume, as we did <i>Volume.2.5</i> in 2015, [but] I’m saving the title <i>Volume.4</i> for a heavier collection in homage to a band from Birmingham whose name escapes me at this moment. We have tons of unreleased material yet to see the light of day. It’s just a case of finding an appropriate outlet for it all and hoping people don’t get sick of us releasing stuff so frequently. One particular record that I’m hoping we can find a home for is a collection of acid tracks that we made in 2015. It’s a pretty coherent album. I guess that might be <i>EP4</i>.</p>
<p class="p1"><b>Certain people have been calling you a &#8216;synthwave&#8217; act. How do you feel about that categorization?</b></p>
<p class="p1">I don’t think anyone who has heard us and knows what synthwave actually is would say that, so I personally find it a reductive and asinine description. I don’t think of us as a retro-sounding band—or even really a synth band, if I’m honest. It’s possible that there’s good synthwave music out there, and no disrespect to anyone who makes it, but it’s not something we listen to or feel an affinity with. Most of it sounds like the <i>Airwolf</i> theme tune, which I’m sure is intentional.</p>
<iframe width='100%' height='120' style='position: relative; display: block; width: 100%; height: 120px;' src='//bandcamp.com/EmbeddedPlayer/v=2/track=4014766481/album=1248245268/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/' allowtransparency='true' frameborder='0'></iframe>
<p class="p1"><b>Have you ever waved at a synth?</b></p>
<p class="p1">I wave at synths all the time, though they rarely wave back.</p>
<p class="p1"><b>Synthy soundscapes are pretty &#8216;hot&#8217; right now thanks to the <i>Stranger Things</i> theme tune, the return of <i>Twin Peaks</i>, and all those Clint Mansell and Cliff Martinez film scores. How could Necro Deathmort best capitalize on this trend?</b></p>
<p class="p1">One of the most frustrating things about this band is that people often tell us that our music sounds like a soundtrack, but that side of things seems like it’s totally closed off to us. It’s a completely separate world from the music scene. I suspect we’ll never get the call as it’s highly unlikely anyone in Tinseltown is familiar with our band. One of our dreams is to score a bleak sci-fi film, but it seems as though Mansell and Martinez have things locked down.</p>
<p class="p1"><b>Which horror film had the biggest impact on your psyche when growing up?</b></p>
<p class="p1"><i>The Omen II</i> terrified me when I was 10. The dude getting chopped in half by the elevator cables stuck with me forever. I think sci-fi films had a much bigger impact on me when growing up. I didn’t properly get into horror films until my late teens. The sci-fi films that had the biggest effect on me when I was younger were <i>Alien</i>, <i>Star Wars</i>, <i>Tron</i> and <i>The Terminator</i>. The visuals and sound design in those films are incredible, and they really fired my imagination when I was young. Then I got into the really stark vibey stuff like <i>The Andromeda Strain</i>, <i>Phase IV</i>, <i>Outland</i>, <i>Westworld</i>, <i>THX 1138</i> and <i>Colossus: The Forbin Project</i>, and that’s when I became obsessed with electronic soundtracks.</p>
<p class="p1"><b>Which one track from your whole catalogue best sums up Necro Deathmort?</b></p>
<p class="p1">That’s a tough one. Possibly &#8216;Odorem Creepus&#8217; from <i>Volume.1</i>, as it was the very first recording we ever made and it kinda kicked things off. I was unsuccessfully trying to work out a Melvins song on a keyboard while AJ manipulated the sound, and I pretty much played every note except the correct ones. It sounded fat, and we were excited by the sonic possibilities of playing heavy doomy music on electronic gear.</p>
<p class="p1"><i>—JR Moores</i></p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/?share=email" target="_blank" title="Click to email"><span></span><span class="sharing-screen-reader-text">Click to email (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-75861" class="share-facebook sd-button share-icon no-text" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-75861" class="share-twitter sd-button share-icon no-text" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-75861" class="share-google-plus-1 sd-button share-icon no-text" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-4823170-75861-59d80b6b4abf4' data-src='//widgets.wp.com/likes/#blog_id=4823170&amp;post_id=75861&amp;origin=bandcampblog.wordpress.com&amp;obj_id=4823170-75861-59d80b6b4abf4' data-name='like-post-frame-4823170-75861-59d80b6b4abf4'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>
				</div>
				<div class="entry-meta">
					This entry was written by <span class="author vcard"><a class="url fn n" href="https://daily.bandcamp.com/author/featurestoriesblog/" title="View all posts by Editorial">Editorial</a></span>, posted on <abbr class="published" title="2017-10-06T11:11:28-0700">October 6, 2017 at 11:11 am</abbr>, filed under <a href="https://daily.bandcamp.com/category/featured-music/" rel="category tag">featured music</a> and tagged <a href="https://daily.bandcamp.com/tag/electronic-music/" rel="tag">electronic music</a>, <a href="https://daily.bandcamp.com/tag/necro-deathmort/" rel="tag">Necro Deathmort</a>. Bookmark the <a href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/" title="Permalink to Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland”" rel="bookmark">permalink</a>. Follow any comments here with the <a href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/feed/" title="Comments RSS to Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland”" rel="alternate" type="application/rss+xml">RSS feed for this post</a>.
					<a class="comment-link" href="#respond" title="Post a comment">Post a comment</a> or leave a trackback: <a class="trackback-link" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/trackback/" title="Trackback URL for your post" rel="trackback">Trackback URL</a>.
				</div>
			</div><!-- .post -->

			<div id="nav-below" class="navigation">
				<div class="nav-previous"><a href="https://daily.bandcamp.com/2017/10/06/daphni-joli-mai-review/" rel="prev"><span class="meta-nav">&laquo;</span> Album of the Day: Daphni, “Joli&nbsp;Mai”</a></div>
				<div class="nav-next"></div>
			</div>

			<div id="comments">



<div class="navigation">
 </div>

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://daily.bandcamp.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="a3fe4f8691" /><input type="hidden" name="_wp_http_referer" value="/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='75861' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="cb329d32be" /></p>
<input type="hidden" name="genseq" value="1507330923" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="38"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
			</div><!-- #comments -->


		</div><!-- #content -->
	</div><!-- #container -->

	<div id="primary" class="sidebar">
				<ul class="xoxo">

			<li id="text-348180390" class="widget widget_text">
				<h3 class="widgettitle">FOLLOW US</h3>
			<div class="textwidget"><div class="follow-us">
<a class="social-newsletter" href="https://bandcamp.com/?newsletter=show#newsletter" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-1.png"></a>
<a class="social-facebook" href="https://www.facebook.com/Bandcamp/" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-2.png"></a>
<a class="social-twitter" href="https://twitter.com/Bandcamp" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-3.png"></a>
<a class="social-instagram" href="https://www.instagram.com/bandcamp" target="_blank"><img src="https://bandcampblog.files.wordpress.com/2017/03/icon-social-4.png"></a>
</div></div>
		
			</li>

			<li id="text-348180391" class="widget widget_text">			<div class="textwidget">Your guide to the world of Bandcamp.</div>
		
			</li>
			
			<li id="search" class="widget widget_search">				
				<h3 class="widgettitle"><label for="s"> &nbsp;</label></h3>
				<form id="searchform" class="blog-search" method="get" action="https://daily.bandcamp.com/">
					<div>
						<input id="s" name="s" type="text" class="text" value="" size="10" tabindex="1" />
						<input type="submit" class="button" value="Go" tabindex="2" />
					</div>
				</form>
			
			</li>

			<li id="text-348180393" class="widget widget_text">
				<h3 class="widgettitle">TOP STORIES</h3>
			<div class="textwidget"><div class="stories-widget"><ul class="display-posts-listing"><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/05/sludge-metal-list/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Melvins" srcset="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="76096" data-permalink="https://daily.bandcamp.com/2017/10/05/sludge-metal-list/melvins-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9Chris Casella&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Melvins-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/05/sludge-metal-list/">Sludge Metal: Doom&#8217;s Filthier&nbsp;Sibling</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/05/wolves-in-the-throne-thrice-woven-interview/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/10/wolves-in-the-throne-room-by-chona-kasinger-600-2.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Wolves in the Throne Room" srcset="https://bandcampblog.files.wordpress.com/2017/10/wolves-in-the-throne-room-by-chona-kasinger-600-2.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/wolves-in-the-throne-room-by-chona-kasinger-600-2.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="75933" data-permalink="https://daily.bandcamp.com/2017/10/05/wolves-in-the-throne-thrice-woven-interview/wolves-in-the-throne-room-by-chona-kasinger-600-2/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/wolves-in-the-throne-room-by-chona-kasinger-600-2.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;All rights reserved&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Wolves-in-the-Throne-Room-by-Chona-Kasinger-600-2" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/wolves-in-the-throne-room-by-chona-kasinger-600-2.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/wolves-in-the-throne-room-by-chona-kasinger-600-2.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/05/wolves-in-the-throne-thrice-woven-interview/">Wolves in the Throne Room Return to Black Metal on “Thrice&nbsp;Woven”</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/04/australian-psych-bandcamp-guide/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/09/beaches-promo-photo-darren-sylvester-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Beaches" srcset="https://bandcampblog.files.wordpress.com/2017/09/beaches-promo-photo-darren-sylvester-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/09/beaches-promo-photo-darren-sylvester-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="75571" data-permalink="https://daily.bandcamp.com/2017/10/04/australian-psych-bandcamp-guide/beaches-promo-photo-darren-sylvester-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/09/beaches-promo-photo-darren-sylvester-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Beaches-Promo-Photo-Darren-Sylvester-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/09/beaches-promo-photo-darren-sylvester-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/09/beaches-promo-photo-darren-sylvester-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/04/australian-psych-bandcamp-guide/">Discover the World of Australian&nbsp;Psych</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/04/talibam-endgame-of-the-anthropocene-review/" style="display: block;"><img width="150" height="150" src="https://bandcampblog.files.wordpress.com/2017/10/a1770420313_16.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/10/a1770420313_16.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/a1770420313_16.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="75754" data-permalink="https://daily.bandcamp.com/2017/10/04/talibam-endgame-of-the-anthropocene-review/a1770420313_16/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/a1770420313_16.jpg" data-orig-size="700,700" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="a1770420313_16" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/a1770420313_16.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/a1770420313_16.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/04/talibam-endgame-of-the-anthropocene-review/">Album of the Day: Talibam!, “Endgame of the&nbsp;Anthropocene”</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/02/kaitlyn-aurelia-smith-feature/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/09/kaitlyn-aurelia-smith-by-faith-silva-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Kaitlyn Aurelia Smith" srcset="https://bandcampblog.files.wordpress.com/2017/09/kaitlyn-aurelia-smith-by-faith-silva-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/09/kaitlyn-aurelia-smith-by-faith-silva-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="74868" data-permalink="https://daily.bandcamp.com/2017/10/02/kaitlyn-aurelia-smith-feature/kaitlyn-aurelia-smith-by-faith-silva-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/09/kaitlyn-aurelia-smith-by-faith-silva-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Kaitlyn-Aurelia-Smith&#8211;by-Faith-Silva-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/09/kaitlyn-aurelia-smith-by-faith-silva-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/09/kaitlyn-aurelia-smith-by-faith-silva-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/02/kaitlyn-aurelia-smith-feature/">Kaitlyn Aurelia Smith Finds Her Inner&nbsp;“Kid”</a></li></ul></p>
<div class="linky"><a href="http://blog.bandcamp.com/category/top-stories/">See All Top Stories › </a></div>
</div>
</div>
		
			</li>

			<li id="text-348180386" class="widget widget_text">
				<h3 class="widgettitle">MOST RECENT</h3>
			<div class="textwidget"><div class="stories-widget"><ul class="display-posts-listing"><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Necro Deathmort" srcset="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="75883" data-permalink="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/necro-deathmort-by-eleanor-short-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Necro-Deathmort-by-Eleanor-Short-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/necro-deathmort-by-eleanor-short-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/">Don’t Call it Synthwave: Navigating Necro Deathmort’s &#8220;Overland”</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/06/daphni-joli-mai-review/" style="display: block;"><img width="150" height="150" src="https://bandcampblog.files.wordpress.com/2017/10/daphni-joli-mai.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/10/daphni-joli-mai.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/daphni-joli-mai.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="75777" data-permalink="https://daily.bandcamp.com/2017/10/06/daphni-joli-mai-review/daphni-joli-mai-2/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/daphni-joli-mai.jpg" data-orig-size="1200,1200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="daphni-joli-mai" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/daphni-joli-mai.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/daphni-joli-mai.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/06/daphni-joli-mai-review/">Album of the Day: Daphni, “Joli Mai”</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/06/bandcamp-essential-releases-oct-6/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/10/7-essential-600-10-06-17.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/10/7-essential-600-10-06-17.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/7-essential-600-10-06-17.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="76069" data-permalink="https://daily.bandcamp.com/2017/10/06/bandcamp-essential-releases-oct-6/7-essential-600-10-06-17-2/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/7-essential-600-10-06-17.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="7-essential-600-10.06.17" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/7-essential-600-10-06-17.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/7-essential-600-10-06-17.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/06/bandcamp-essential-releases-oct-6/">This Week’s Essential Releases: Afrobeat, Glam Pop, Experimental Synth &amp; More</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/05/sludge-metal-list/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Melvins" srcset="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="76096" data-permalink="https://daily.bandcamp.com/2017/10/05/sludge-metal-list/melvins-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9Chris Casella&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Melvins-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/10/melvins-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/05/sludge-metal-list/">Sludge Metal: Doom&#8217;s Filthier Sibling</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/10/05/hush-hush-records-profile/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/09/label-hush-hush-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Hush Hush" srcset="https://bandcampblog.files.wordpress.com/2017/09/label-hush-hush-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/09/label-hush-hush-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="75887" data-permalink="https://daily.bandcamp.com/2017/10/05/hush-hush-records-profile/label-hush-hush-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/09/label-hush-hush-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="label-Hush-Hush&#8211;600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/09/label-hush-hush-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/09/label-hush-hush-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/10/05/hush-hush-records-profile/">From Night Bus to Worldwide with Hush Hush Records</a></li></ul></p>
<div class="linky"><a href="http://blog.bandcamp.com/category/featured-music/">See All Stories › </a></div>
</div>
</div>
		
			</li>

			<li id="text-348180385" class="widget widget_text">
				<h3 class="widgettitle">BANDCAMP UPDATES</h3>
			<div class="textwidget"><div class="stories-widget"><ul class="display-posts-listing"><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/09/12/announcing-bulk-edit/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Announcing Bulk Edit" srcset="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="65987" data-permalink="https://daily.bandcamp.com/2017/09/12/announcing-bulk-edit/bulk-edit-1-600/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="bulk-edit-1-600" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/08/bulk-edit-1-600.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/09/12/announcing-bulk-edit/">Announcing Bulk Edit</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/08/04/update-on-fridays-transgender-law-center-fundraiser/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/08/tlc-image-600-1.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="Transgender Law Center" srcset="https://bandcampblog.files.wordpress.com/2017/08/tlc-image-600-1.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/08/tlc-image-600-1.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="65419" data-permalink="https://daily.bandcamp.com/2017/08/04/update-on-fridays-transgender-law-center-fundraiser/tlc-image-600-1/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/08/tlc-image-600-1.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tlc-image-600-1" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/08/tlc-image-600-1.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/08/tlc-image-600-1.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/08/04/update-on-fridays-transgender-law-center-fundraiser/">An Update on Friday’s Fundraiser for the Transgender Law&nbsp;Center</a></li><li class="listing-item" style="clear: both;"><a class="image alignleft " href="https://daily.bandcamp.com/2017/08/03/labels-artists-join-us-in-donating-todays-profits-to-transgender-law-center/" style="display: block;"><img width="150" height="100" src="https://bandcampblog.files.wordpress.com/2017/08/tlc-600-5.jpg?w=150" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://bandcampblog.files.wordpress.com/2017/08/tlc-600-5.jpg?w=150 150w, https://bandcampblog.files.wordpress.com/2017/08/tlc-600-5.jpg?w=300 300w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="65187" data-permalink="https://daily.bandcamp.com/2017/08/03/labels-artists-join-us-in-donating-todays-profits-to-transgender-law-center/tlc-600-5/" data-orig-file="https://bandcampblog.files.wordpress.com/2017/08/tlc-600-5.jpg" data-orig-size="600,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tlc-600-5" data-image-description="" data-medium-file="https://bandcampblog.files.wordpress.com/2017/08/tlc-600-5.jpg?w=300" data-large-file="https://bandcampblog.files.wordpress.com/2017/08/tlc-600-5.jpg?w=600" /></a> <a class="title" href="https://daily.bandcamp.com/2017/08/03/labels-artists-join-us-in-donating-todays-profits-to-transgender-law-center/">Over 200 Labels &amp; Artists Join Us in Donating Friday’s Profits to the Transgender Law&nbsp;Center</a></li></ul></p>
<div class="linky"><a href="https://daily.bandcamp.com/category/bandcamp/">See All Updates › </a></div>
</div>
</div>
		
			</li>

			<li id="text-348180384" class="widget widget_text">
				<h3 class="widgettitle">DON&#8217;T MISS THE BC WEEKLY</h3>
			<div class="textwidget"><div class="weekly">
<a href="http://bandcamp.com/?play=1"><img src="https://bandcamp.com/bcweekly.jpg" width="210" /></a>

<div class="listen"><a href="http://bandcamp.com/?play=1">Listen Now &rsaquo; </a></div>

</div></div>
		
			</li>

			<li id="text-348180383" class="widget widget_text">			<div class="textwidget"><a class="sidebarlogo" href="http://bandcamp.com"></a>

<div class="blurb">Bandcamp is a global community where millions of fans discover new music, and directly connect with and fairly compensate the artists who make it. </div></div>
		
			</li>
		</ul>
	</div><!-- #primary .sidebar -->

	<div id="secondary" class="sidebar">
		<ul class="xoxo">
			<li id="search">
				<h3><label for="s">Search</label></h3>
				<form id="searchform" class="blog-search" method="get" action="https://daily.bandcamp.com/">
					<div>
						<input id="s" name="s" type="text" class="text" value="" size="10" tabindex="1" />
						<input type="submit" class="button" value="Find" tabindex="2" />
					</div>
				</form>
			</li>

<li id="linkcat-1356" class="linkcat"><h3>Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://wordpress.com/">WordPress.com</a></li>
<li><a href="http://wordpress.org/">WordPress.org</a></li>

	</ul>
</li>

			<li id="rss-links">
				<h3>RSS Feeds</h3>
				<ul>
					<li><a href="https://daily.bandcamp.com/feed/" title="Bandcamp Daily latest posts" rel="alternate" type="application/rss+xml">All posts</a></li>
					<li><a href="https://daily.bandcamp.com/comments/feed/" title="Bandcamp Daily latest comments" rel="alternate" type="application/rss+xml">All comments</a></li>
				</ul>
			</li>

			<li id="meta">
				<h3>Meta</h3>
				<ul>
					<li><a href="https://wordpress.com/start?ref=wplogin">Register</a></li>
					<li><a href="https://bandcampblog.wordpress.com/wp-login.php">Log in</a></li>
					
				</ul>
			</li>
		</ul>
	</div><!-- #secondary .sidebar -->
<script type='text/javascript'>
								var _gaq = _gaq || [];
								_gaq.push(['_setAccount', 'UA-4189134-6']);
_gaq.push(['_trackPageview']);

								(function() {
									var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
									ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
									var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
								})();
							</script>

	<div id="footer">
		<span id="generator-link"><a></a></span>
		<span class="meta-sep">|</span>
		</span>
	</div><!-- #footer -->

</div><!-- #wrapper .hfeed -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201740y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/bandcampblog.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/bandcampblog.wordpress.com\/wp-login.php?action=logout&_wpnonce=421f67d8c6","homeURL":"https:\/\/daily.bandcamp.com\/","postID":"75861","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="4823170" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://daily.bandcamp.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Bandcamp Daily" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="be1d285294" /><input type="hidden" name="_wp_http_referer" value="/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/daily.bandcamp.com\/2017\/10\/06\/dont-call-it-synthwave-navigating-necro-deathmorts-overland\/":75861};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/10/06/dont-call-it-synthwave-navigating-necro-deathmorts-overland/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			<div class="recaptcha" id="sharing_recaptcha"></div><input type="hidden" name="recaptcha_public_key" id="recaptcha_public_key" value="6LcYW8MSAAAAADBAuEH9yaPcF7lWh11Iq62ZKtoo" />
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
		<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"4823170","siteName":"Bandcamp Daily","siteURL":"https:\/\/daily.bandcamp.com","icon":"<img alt='' src='https:\/\/bandcampblog.files.wordpress.com\/2017\/03\/bc-site-icon1.png?w=50' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/sandbox-162","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/bandcampblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F10%2F06%2Fdont-call-it-synthwave-navigating-necro-deathmorts-overland%2F","themeURL":"","xhrURL":"https:\/\/daily.bandcamp.com\/wp-admin\/admin-ajax.php","nonce":"6e3a25fb68","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"afb0636d96\" \/>","referer":"https:\/\/daily.bandcamp.com\/2017\/10\/06\/dont-call-it-synthwave-navigating-necro-deathmorts-overland\/","canFollow":"1","feedID":"49616248","statusMessage":"","customizeLink":"https:\/\/bandcampblog.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fbandcampblog.wordpress.com%2F2017%2F10%2F06%2Fdont-call-it-synthwave-navigating-necro-deathmorts-overland%2F","postID":"75861","shortlink":"http:\/\/wp.me\/pkeJ4-jJz","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/daily.bandcamp.com\/75861","statsLink":"https:\/\/wordpress.com\/stats\/post\/75861\/daily.bandcamp.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Sandbox 1.6.2","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 4,447 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/bandcampblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F10%2F06%2Fdont-call-it-synthwave-navigating-necro-deathmorts-overland%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/daily.bandcamp.com\/wp-admin\/admin-ajax.php","nonce":"0a3ae66989","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/bandcampblog.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdaily.bandcamp.com%2F2017%2F10%2F06%2Fdont-call-it-synthwave-navigating-necro-deathmorts-overland%2F","blog_id":"4823170","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=4823170&v=wpcom&tz=-7&user_id=0&subd=bandcampblog","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJx9T0kOwjAM/BCpC4jlgngKCqkBp9mwE5bfEyQKPaCebM2MZ8ZwT8rEkDFksAId3shgejRWZjCifFHJlTMFAUc9ClwLFrzo0DnkQUzBuNJVshqZ6H09VIzJPRtPYcJRd5VXR83gtWTkuql4Q2Z6m32xKQeTKYa3w3f7V0rSr8cYt/Ubfn5GM1b9yTKaYxF0YDEnbXo1AFP9ehKPWS2bFg41GU6R/YQ+Rcnq5DQxyEUzhfMw69He7+ardrHezjeL1r4A2AKnLQ=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'4823170','blog_tz':'-7','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'4823170','v':'wpcom','tz':'-7','user_id':'0','post':'75861','subd':'bandcampblog'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1oV0pFNEwueXFaVXlyMGwvVG9ES35pOVYlRUVhdVJ2TTczd3dDaTdGUm83UEpzfHZlbl1HSkppTG05Rzh1fCxhSDBpPWlCW0kxR2puWUp3JWl6TENpPU5IUmt2LjBRckc9ZF1YU1s1SUYzSGh5OWgmK0lUbURLZ040fHZWUzNjZWY0QWs5UkQvZGRQX0YvU1hndVR6ayx5bCVobnRfempTUXZ4M1BhfldQNk92bHo4aCU3VjV1djhhSHo9QlVnUD9BViY4JjZwbm0uZD9HRE5ZQ1BtNWp+UHhoNk0rRnVzWm5lYSxEbGwwMCY5MGMyLS5BUVhbZDRyWDJESU5WUzN0LFU9biVjU1A2UXY4dURrTHA='}]);
_stq.push([ 'clickTrackerInit', '4823170', '75861' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>